[Resolved] Small bug with Blog Post comments

A place for comments, criticism and suggestions about the website in general.
User avatar
wintermute
Established Member
Posts: 69
Joined: Sat Feb 23, 2008 8:50 am

[Resolved] Small bug with Blog Post comments

Postby wintermute » Sun Feb 01, 2009 3:37 am

If you click on "reply" on the blog posts in the front page, you're taken to the post in the "Blog Post" forum - which is reply-disabled.

Similarly the comments counter seems to be related to the posts in that forum rather than the Blog Discussions forum.

I see that the latest post is what shows up on the front page - so unless that behaviour can be changed somehow, can the links be diverted to the discussion forum? It doesn't seem to *quite* work at the moment

I know this is early days though :)
Cicero wrote:"Neither can embellishments of language be found without arrangement and expression of thoughts, nor can thoughts be made to shine without the light of language"

Karl
Administrator
Posts: 493
Joined: Sat Jan 05, 2008 9:41 am

Re: Small bug with Blog Post comments

Postby Karl » Sun Feb 01, 2009 9:13 am

Yeah, that is a pain. I originally thought that the first post in the topic would appear on the front page but then I found out that wasn't the case, hence the current set up. One option may be to delete the link and comment count from the front page template and just remember to always add a link at the bottom of the post to take visitors to the duplicate, comment-enabled thread.

User avatar
wintermute
Established Member
Posts: 69
Joined: Sat Feb 23, 2008 8:50 am

Re: Small bug with Blog Post comments

Postby wintermute » Sun Feb 01, 2009 9:22 am

I've had a think about it, it would be possible to make it fetch only the first post, but then it might reorder the blog posts when people comment on them, which isn't really what we're looking for.

Might ask the guys in the Portal XL 5 dev forum and see what they can come up with, someone else must have considered this
Cicero wrote:"Neither can embellishments of language be found without arrangement and expression of thoughts, nor can thoughts be made to shine without the light of language"

Karl
Administrator
Posts: 493
Joined: Sat Jan 05, 2008 9:41 am

Re: Small bug with Blog Post comments

Postby Karl » Sun Feb 01, 2009 10:18 am

Well, whadaya know?There was an option in the Admin Control Panel to fix this very issue. I just hadn't spotted it before because the description of it isn't very helpful. I guess I can delete the duplicate forum, now. :)

User avatar
wintermute
Established Member
Posts: 69
Joined: Sat Feb 23, 2008 8:50 am

Re: Small bug with Blog Post comments

Postby wintermute » Sun Feb 01, 2009 10:32 am

hahaa how funny is that, well at least it's fixed
Cicero wrote:"Neither can embellishments of language be found without arrangement and expression of thoughts, nor can thoughts be made to shine without the light of language"